We will be undergoing scheduled maintenance during this time.
Posted Apr 15, 2026 - 11:38 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 15, 2026 - 11:31 BST
Scheduled
We are writing to inform you that we will be carrying out a planned full platform disaster recovery test on Saturday 18th of April. During this period, the following services will be unavailable between 10AM to 3PM:
This planned test is an important part of our resilience programme and is designed to validate our recovery processes.
Services will be restored as soon as testing and post-recovery verification have been completed. We recommend that you plan accordingly for this period of disruption.
Posted Mar 30, 2026 - 10:24 BST
This scheduled maintenance affects: eConveyancer, econveyancer.hellosmoove.com, eCSearches, DigitalMove, Connect, and Smoove Web Applications.